解决“配置文件现在需要绝密的短语密码(blowfish_secret)”

学习vps操作已经到了配置phpmyadmin阶段。我采用的方式为通过FTP上传phpmyadmin压缩包然后通过upzip命令解压的方法,但是按照要求配置config.inc.php文件的时候出现问题,昨天晚上测试的时候一直出现配置文件现在需要绝密的短语密码(blowfish_secret)错误,今天早上继续学习。我把昨天编辑好的config.inc.php文件下载到本地,发现$cfg['blowfish_secret'] = '';还是为空,说明属性不对。于是我就通过vi命令,直接在PUTTY上进行编辑保存。测试后可以使用。一般解压了phpmyadmin后需要改变的文件有以下几个:

首先,把下载解压的 phpMyAdmin 文件中有一个文件“config.sample.inc.php”,这是phpMyAdmin配置文件的样本文件,我们需要把该文件复制,然后重命名为“config.inc.php”,config.inc.php是phpMyAdmin的配置文件,上传服务器时必须上传该文件。
其次,用 DW 或任意编辑器打开 config.inc.php 搜索下面一行代码:
$cfg['blowfish_secret'] = ”;
将后面单引号里面随便填入个字符串即可!
第三,记得重起Apache 。

未经允许不得转载,或者注明出处:https://www.yd631.com/blowfish-secret-err/

麦子猜您可能还喜欢以下内容: