WordPress 3.7升级可能出现的几个问题

在上周末如果是使用WordPress 3.7程序的博主应该都有看到后台提醒我们可以升级,先肯定是英文版本的升级,之后才有中文升级包,具体的WordPress 3.7新版本增加了自动更新升级、推广强密码功能以及本地化更准确。不论是何种版本在升级的时候我们一定要小心,首先是否有必要升级,如果是安全问题我们肯定是需要的,如果是功能类的我们可以暂时不升级等升级包完善后再去,因为麦子不希望大家的博客都作为小白鼠。

在升级的过程中会出现各种各样的问题,我们可以从发布官网下面的留言都有看到很多人升级之后出现各种问题,因此我们在升级WP的时候需要注意以下几个问题:

第一,手工升级。

WordPress 3.7升级之后会添加自动升级包,以后不要我们手工操作是否升级直接升级,这类功能对于站多的来说是有用的,在官方发布最新版本之后就第一时间升级,可以保证程序的最新版本。但是并不是最新的版本都是完美的,很多时候我们看到开始发布的都有问题,导致不兼容等,所以麦子不建议大家用这个功能,可以在wp-config.php文件下添加

define( 'AUTOMATIC_UPDATER_DISABLED', true );

禁止自动升级,以后有新版本等待手工更新。

第二,兼容问题。

我建议在本地升级测试之后,或者备份文件之后再升级,上午麦子升级了一个博客发现兼容性很差,和之前一个主题不兼容,所以有备份的话可以恢复,不能太相信官方的最新版本兼容性。

第三,编辑问题

在升级版本之后会出现theme-editor.php的警告提示,这是开始版本的问题,目前已经修复。

第三,权限问题

如果是用VPS主机的可能由于权限问题导致下载不到最新安装包,那需要我们设置目录权限,具体的可以参考这里

总之,升级是有必要的,但我们一定要做好准备工作,以防万一。

未经允许不得转载,或者注明出处:https://www.yd631.com/wordpress-3-7/

麦子猜您可能还喜欢以下内容: